EC-CUBE 3 のシステム要件を満たしているかチェックするスクリプトを書いた

EC-CUBE 3 のシステム要件を満たしているかチェックするスクリプトを書いた

EC-CUBE 3.02 あたりで取り込まれましたので現在は不要なものになります
ref #528 モジュールに関する警告を表示 by nobuhiko · Pull Request #535 · EC-CUBE/ec-cube

EC-CUBE 開発コミュニティを見ていても、そのエラーが要件を満たしていて出るものなのか、そうでないのかがさっぱりわからないのでプログラムで解決してみた

nobuhiko/eccube3-install-check

使い方

ダウンロード

上のリンクからダウンロードをしたら、EC-CUBE3を設置予定のサーバーに置いて(もしくはEC-CUBE3のhtml以下に置いて)、install_check.phpにアクセスしてください

[推奨PHPライブラリ]APC 拡張モジュールが有効になっていません。

↑こんな感じのエラーが出るので、出たらそこに問題があるんだな、と思ってください

エラーが出たからといって絶対動かないかどうかはわかりませんし、逆もまたしかりです
このサーバーで試したらこうなった、とかありましたらご報告ください
反映なりテストなりします

コメントを残す