muninをインストールしたけどhtmlが表示されないとき

muninをインストールしたけどhtmlが表示されないとき

muninをインストールしたけど/muninにアクセスしても表示されない (;´Д`)
なんだかハマったのです

インストール

CentOS 6 – Munin – インストール/設定 : Server World

CentOS6の場合はepelが標準で入っているのでインストールは簡単

/var/log/munin/munin-html.logを見たらエラーっぽいのが出てました

~~~
2012/04/03 19:10:12 [FATAL] There is nothing to do here, since there are no nodes with any plugins. Please refer to http://munin-monitoring.org/wiki/FAQ_no_graphs at /usr/share/munin/munin-html line 3
~~~

http://munin-monitoring.org/wiki/FAQ_no_graphsを見てみるとこんなことが書いてあります

No plugins installed on the munin node

Plugins that munin-node uses are usually to be found in /etc/munin/plugins (or /etc/opt/munin/plugins). If the directory is empty you will need to fill it. The directory should have been filled by the package installation script or by you when you read the INSTALL instructions.

You can fill it manually by symlinking to files in /usr/share/munin/plugins (or /opt/munin/lib/plugins). Or automatically by running munin-node-configure –shell | sh -x. This will which plugins it thinks are suitable on your system and make the symlinks.

After making all the symlinks restart munin-node.

Then wait 5 to 10 minutes before re-loading the munin web pages to see graphs.

って書いてあるので

~~~
sudo munin-node-configure –shell | sh -x
sudo service munin-node restart
~~~

こうして5分待ってみるけど再度エラー (;´Д`)

んんん、なんだろ。。とさらに調べます

NFSv4のエラー, クラッチ系修理など, muninのエラー – What's the punch line?(2010-05-03)

ふむふむ、localhostじゃだめなのね、ってことでやったらこれがビンゴだったようです
htmlは作成されました

~~~
2012/04/03 22:30:10 Opened log file
2012/04/03 22:30:10 [INFO] Starting munin-html, getting lock /var/run/munin/munin-html.lock
2012/04/03 22:30:10 [INFO] Process 30164 is dead, stealing lock, removing file
2012/04/03 22:30:10 [INFO] Releasing lock file /var/run/munin/munin-html.lock
2012/04/03 22:30:10 [INFO] munin-html finished (0.46 sec)
~~~

でもグラフが出ない。。

/var/log/munin/munin-update.logにもwarning

~~~
2012/04/03 22:40:03 [WARNING] Service munin_stats on x86-07.phx2.fedoraproject.org/hostname:4949 returned no data for label update
~~~

ん、x86-07.phx2.fedoraproject.orgって何だろう…?

sudo vim /etc/munin/munin.conf
~~~
[x86-07.phx2.fedoraproject.org]
address hostname
use_node_name yes
~~~

最初のサイトの通りに書いたつもりが間違っとりますね。。
~~~
[hostname]
address 127.0.0.1
use_node_name yes
~~~
こうして再起動したらtyなんと動いたよーー
ただの盆ミスでした (;´Д`)

muninは入れ方によってインストール先が違ったり、簡単なんだけどややこしいな〜